My Atari Ethernet Experience

Getting ethernet on my Atari computers has been an unfortunately long and difficult process. It was one problem after another and I figure if anything good can come of all of this, I can warn other Atari users of the potential problems that they might have and help them to decide which solution might be best for them.

My very first Atari ethernet experience involved an Asante SCSI Ethernet adapter. I bought one of these adapters from eBay just to give it a shot and see what could be done with it. After receiving the adapters I quickly found out that no person including me have ever been able to get an Atari to even BOOT with this adapter connected. I gave up and decided to put the adapter in the closet. There were other serious problems with this adapter from technical information that I found out from Asante including that if the adapter is addressed too fast it crashes. Thus I could not even get the adapter to function on a Mac powerbook as the scsi bus on there was too fast as well.

After a long amount of time passed, I finally scrounged up the courage to attempt to build a Genius parallel port ethernet adapter rom port adapter. This particular ethernet device went off the market very soon after the design was completed and the product started selling which creates for a lot of problems. In the end I would not recommend this method to anyone but to a person who is very seriously interested in electronics and has a lot of money to burn. Building this or any adapter requires somewhere around $100 in circuit board building materials. I somewhat outlined what was required in another article. The more professional you go, the more exponentially higher the cost is. My lack of experience with the press-n-peel film made for a rather poor build quality. In the end I could not produce a good PCB so I decided to prototype the whole board. It did not work very well and in the end I found out the reason was that my Genius adapter was based on the RTL8002 chipset versus the required RTL8012 chipset. I found that the RTL8002 chipset had a beta driver in production but I gave up nonetheless.

Soon after however some new light shone. I found the EtherNEC project. Easy to build, components I could find. I ordered the ISA slot. I ordered the pin headers and I made the board. The board turned out okay but not great. A lot of fixes had to go into it. Because the board was home-made the holes did not have through-hole metal. The result? Soldering the pin rows was extremely difficult and in the end did not work all that well. The adapter didn't work, the computer didn't boot. After probably over 100 hours of trying (and wasting my time), I gave up. The reason it never worked was because I was using incompatible NE2000 cards! Building and debugging this board for me (a PCB building newbie) took a loooong time.

Then I found a Daynport SCSI Link adapter. Interesting, I would imagine this would work great right? Perhaps not. I did not have a valid version of HD-Driver, but rather only an old one that did not yet support SCSI bus arbitration. However even "borrowing" a copy of HD-driver did not prove helpful due to the fact that my Daynaport hardware is apparently faulty, though I am simply not sure as of yet.

As I am getting pretty frustrated at this point, I decided to order an EtherNEC. But rather than just ordering one, I decided to order 2 since I was ordering professional boards and was sure that they would work. I wanted to provide ethernet access for both my TT and Falcon. Bceause this adapter is "ne2000" compatible I did not order the ISA cards as Lyndon had run out of them anyway. This was nothing short of a mistake. As far as the ordering process was concerned, Lyndon accepts paypal which made it very easy for me. I paid somewhere around $80 for the two adapters. Like other overseas shipments this should take a while right? Nope. It came in less than a week. I found a few ISA ne2000 cards lying around at work. When I tried it, three of them that I tested did not work at all. One of them labeled "UMC9008" did - sort of. During the development of ozk's driver, I began to consult with him about the troubles I was having. He made some fixes in his driver that helped out but nonetheless this card refused to work. So I went out and bought two brand new Netgear NE2000 cards at $20 a piece. Complete waste of money ;-) Then my roomate found an RTL8019 card in a trash pile (literally) for me. I tried it out and it works great!

The moral of the story? The ethernec works fabulous but don't ignore the warning. Either make sure you have an RTL8019 chipset based ISA NE2000 card or have Lyndon send you one that he has tested. It might save you a lot of headaches and in my case money. Unfortunately it seems this card is not completely NE2000 compatible as it is labeled but is instead compatible with a number of NE2000 cards. I have no experience with the Genius adapter as I did not order the hardware from Elmar, but I hear this adapter works better in some instances then the EtherNEC and worse in others. It's really anecdotal. The Dayna should have worked. It's worked somewhat well for most people, I think that I have faulty hardware. Even so if you don't own a recent copy of HD-Driver, you will need one that supports bus arbitration and that's additional dollars you might not want to spend.

So what happens from here? I am waiting on my copy of HD-Driver 8 and hopefully I will be able to get the SCSILink adapter working on one of my Atari's too. If I can't however, I plan to get a mac and test the hardware. If it works, I plan on shipping it to Roger Burrows for further analysis ;-) I have a working EtherNEC on my Falcon and once I find another good ISA NE2000 card, I will have a working EtherNEC on my TT. Transfer speeds on the EtherNEC are absolutely absurd and the best I have heard yet. Over 300K/sec on a TT using Ozk's drivers. Over 80K/sec on my unaccelerated Falcon. Finally I have ethernet on my Atari and I must say, I'm impressed :-)

Article Type: